//This java program accepts a number of user
//which tells the program that how many lines
//of the pattern will be printed and then prints
//the pattern of the given number of lines.
/*Sample Input : 7
Sample Output :
7
767
76567
7654567
765434567
76543234567
7654321234567 */
//For a left aligned version of this pattern
//visit: Java Programs: Printing a pyramid pattern of digits 8 (Java)
import java.util.*;
class pattern
{
public static void main()
{
System.out.print("Enter the number of lines you want : ");
Scanner sc=new Scanner(System.in);
int n=sc.nextInt();
int i,j,k=n,l=1;
for(i=1;i<=n;i++)
{
for(j=n;j>=i+1;j--)
{
System.out.print(" ");
}
k=n;
for(j=1;j<=i;j++,k--)
{
System.out.print(k);
}
k=k+2;
for(j=1;j<=i-1;j++,k++)
{
System.out.print(k);
}
System.out.println();
}
}
}
//Author : Mayank Rajoria
//which tells the program that how many lines
//of the pattern will be printed and then prints
//the pattern of the given number of lines.
/*Sample Input : 7
Sample Output :
7
767
76567
7654567
765434567
76543234567
7654321234567 */
//For a left aligned version of this pattern
//visit: Java Programs: Printing a pyramid pattern of digits 8 (Java)
import java.util.*;
class pattern
{
public static void main()
{
System.out.print("Enter the number of lines you want : ");
Scanner sc=new Scanner(System.in);
int n=sc.nextInt();
int i,j,k=n,l=1;
for(i=1;i<=n;i++)
{
for(j=n;j>=i+1;j--)
{
System.out.print(" ");
}
k=n;
for(j=1;j<=i;j++,k--)
{
System.out.print(k);
}
k=k+2;
for(j=1;j<=i-1;j++,k++)
{
System.out.print(k);
}
System.out.println();
}
}
}
//Author : Mayank Rajoria
No comments:
Post a Comment